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SuperReport Pro 
Version 3.2.1 

Release notes 

October 30, 2014 

Published by e-Node worldwide 
http://www.e-node.net/srp 

System requirements 

SuperReport Pro version 3.2 is compatible with 4th Dimension v11, v12, v13, v14 and above, for both 
Macintosh and Windows. It requires MacOS X 10.5 or higher (Intel only) and Windows XP SP3 or 
better. 

Version 3.2 – New manuals 

§ The Developer Manual and the User Guide have been entirely redesigned. 
§ Many additions/fixes to the Developer Manual: check it out! 

Important Note regarding Constants 

§ Many constants were removed from other themes when they were duplicates of SRP Object 
Properties or SRP Style Properties. You may need to perform a Replace all in 4D design mode 
looking for the old constant name and replacing it everywhere with SRP_Object_XXX or 
SRP_Style_XXX. Edit > Find in design (old name) then Replace in content (new name). 

o e.g. removed SRP_Variable_Kind, use SRP_Object_Kind instead 
o e.g. removed SRP_Variable_FontName, use SRP_Style_FontName instead 

§ See the Common properties: Objects and Styles section on page 84 of the new Developer 
Manual. 

Version 3.2.1 

§ Better font usage in dialogs (specially on Windows) 
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Version 3.2 – New commands 

§ SR_GetObjectsByPropertyValue to get all object numbers having the specified property set to the 
specified value: 
SR_GetObjectsByPropertyValue (ReportRef:L; Property:T; Value:T; ObjNumArray:AL; 
ComparisonMode:L) → Error:L 

o e.g. get all instances of a given 4D variable on the report: 
ARRAY LONGINT($array;0) // will contain the Object numbers 
$err:=SR_GetObjectsByProperty ($report; SRP_Variable_Source; "vVarName"; $array) 

§ SR_AbortPrinting to abort printing from a SuperReport Pro script (Start or Body script, or any 
object script 

Version 3.2 – New properties 

§ SRP_Table_NumFooters, SRP_Table_DrawFooters: see below “New feature: footers in table 
objects”  

§ SRP_Report_WinPrinter, SRP_Report_MacPrinter: see below “Changes regarding Page 
setup” 

§ SRP_Object_DashStyle: “Dash” style property for dotted lines (line pattern) 
o category: Object 
o name: SRP_Object_DashStyle 
o value: "strs" 
o type: integer 
o access: read/write/persistent 
o XML name: "stroke" 
o default: 0 
o min: 0 
o max: 4 

§ 0 - solid _________ 
§ 1 - dash - - - - - - - 
§ 2 - dot . . . . . . . . . .  
§ 3 - dash dot _._._._._._. 
§ 4 - dash dot dot _.._.._.._.. 
 

See http://msdn.microsoft.com/en-us/library/windows/desktop/ms534104(v=vs.85).aspx 
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§ SRP_Report_Scale to scale the report independently from the printer driver - previous 
SRP_Report_Scale renamed to SRP_Report_Zoom (view scaling in the editor), see “Changes 
regarding Constants” 

o Value: "resc" 
o XML attribute name: "reportScale" 
o Type: real 
o Range: 0.1 (10%) - 10.0 (1000%) 

Version 3.2 – New feature: footers in table objects 

§ Support for footer in table objects 
o footer is drawn only when "Draw columns" is checked and there are any data; otherwise 

only the header is drawn (if SRP_Table_DrawColumns # 2) 
o footer cells are evaluated at the end of table printing (variable substitution) 
o added table's footer related constants 

§ Number of rows in footer constant/property 
o category: Table 
o name: SRP_Table_NumFooters 
o value: "ftrn" 
o type: integer 
o access: read/write/persistent 
o default: 0 
o usage: number of rows in the footer 

§ Draw footer constant/property 
o category: Table 
o name: SRP_Table_DrawFooters 
o value: "fodr" 
o type: bool 
o access: read/write/persistent 
o default: False 
o usage: footer is not drawn when False (0) 

§ SRP_Object_Kind for a table's footer object returns "Footer": SRP_ObjectKind_Footer can be 
used 
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§ SRP_TableFooterRowMask with value "F000" can be used in "SRP Get Objects Types" 
constants ("F001" is the first row of a footer) 

o to access the footer rows of a table object, use SRP_TableFooterRowMask: 
ARRAY LONGINT($aObjects;0x0000) 
$err:=SR_GetObjects ($report;$object;String(1;SRP_TableFooterRowMask);$aObjects) 
 // get cells in the footer row 1 

o the number of footer rows is returned by:  
SR_GetLongProperty ($report;$object;SRP_Table_NumFooters) 

§ Use AreaList Pro v9.7 or higher to print AreaList Pro areas with their footers using 
SuperReport Pro 

§ Constants for Table's footer objects (SRP_Footer_@ - identical to corresponding 
SRP_Header_@) 

Version 3.2 – Changes regarding Fonts 

§ Font popups on MacOS now use FONT LIST with * to get font names (Bold & 
Italic/Oblique are filtered) 

o localized font names are returned by 4D therefore some combinations may be missing 
§ Font panel (Mac) now displays the font name, not family name 
§ Font size increase/decrease now steps by one point, not by 25% of current size 
§ Note: GDI plus (used by SuperReport Pro on Windows) does not support OTF fonts. 
§ Underline and strike-through are now in text color, not black 
§ Windows only: changed position of underline (one pixel down) and strike-through (2/3 of the 

ascent + 1) 
§ Strike-through menu item in Object > Font Style submenu (menu ID 1205) 

Version 3.2 – Changes regarding Page setup 

§ Support for getting the device name from the platform specific page/job setup 

§ Device name (Windows) constant/property 
o category: Report 
o name: SRP_Report_WinPrinter 
o value: "Wprn" 
o type: text 
o access: read only 
o usage: get the device name from the binary DEVNAMES structure stored in the 

SRP_Report_DeviceNames property 
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§ Device name (MacOS) constant/property 
o category: Report 
o name: SRP_Report_MacPrinter 
o value: "Mprn" 
o type: text 
o access: read only 
o usage: get the device name from the page setup XML stored in the 

SRP_Report_PageFormat property 
§ "Landscape" attribute is always stored in the report (even if using default of "0") 
§ When "landscape" attribute is present in the report XML, it is always used to modify the 

platform native page setup 
§ When a page setup is done, the old PageSetup attribute is removed (MacOS 7 page setup from 

converted reports) 
§ When there is no platform native page setup, report size is used to define the paper instead of 

the printer's default page setup (assuming a page setup was done on the other platform) 
§ When validating the page setup, margins allow a small difference (to accommodate inexact real 

arithmetic) without reporting "page setup changed" 
§ Multi-page reports design - the editor can display several pages (1 – 16) – no need to play with 

custom page sizes to access objects on second page or beyond 
o new report property: SRP_Report_EditNumberPages:nump:S 
o accessed in the editor: Edit > Report Options... "Number of pages in editor" 

§ When loading old report on Windows, the landscape setting should be correctly honored 
§ Ability to scale the report independently from the printer driver; see Edit > Report Options > 

Scale 

Version 3.2 – Changes regarding Constants 

§ Removed constants which are present in SRP Object Properties or SRP Style Properties from 
other themes 

o e.g. removed SRP_Variable_Kind, use SRP_Object_Kind instead 
o e.g. removed SRP_Variable_FontName, use SRP_Style_FontName instead 

§ Removed SRP_Print_ValidateJobSetup, SRP_Report_PageSetupDlg, SRP_Report_PrintDlg 
§ Renamed SRP_Print_WinOpenPreview to SRP_Print_WinOpenCreatedFile 
§ Added SRP_Error_Aborted having value -1000: reported when the user aborts script 

processing (e.g. on syntax error) 
§ New option bit to "SRP  Export Flags": SRP_Export_NoProgress (see “Other new features” 

below) 
§ Renamed constant SRP_Report_Scale to SRP_Report_Zoom (view scaling in the editor) 
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Version 3.2 – Other new features 

§ German localization 
§ Fonts in the dialogs now default to the application font 
§ Support for reordering the objects (print order) 

o menu item 242 - Object -> Order By Position - selected objects are re-ordered by the 
top/left position 

o menu item 243 - Object -> Reverse Order - selected objects are re-ordered in the 
reverse order 

§ Added a new toolbar object and menu item: Dash Style   
o see above “SRP_Object_DashStyle” 

§  Implemented progress for export (export in the editor no longer uses SRP_Area_PreviewFlags) 
o new option bit to "SRP  Export Flags": SRP_Export_NoProgress 
o File->Export will honor SRP_Export_NoProgress bit of SRP  Export Flags 
o MESSAGES OFF is honored (sets SRP_Export_NoProgress in the implicit options) 

when using compatibility API for printing/export 
§ Improved picture printing on Windows (low-resolution pictures were used) 
§ Modified DataSource object to be "selectable" (only by code, not in interface; property is not 

persistent) 
§ Improved 4D v14 support 
§ "Show Calculated Value" checkbox in Variable & Field properties dialog is now read-only to 

not confuse users 
§ When converting old SRP 2.x reports, sections marked to not print are converted with 

SRP_Object_Export = 0 
§ For consistency, renamed SubHeader/SubTotal to Break Header/Break Footer (used in menus 

for sections not present in the report); note that section names are stored in the report 
§ Renamed the SuperReport Pro variable SRObjectID to SRObjectPrintRef (SRObjectID kept 

for compatibility) 

Version 3.2 - Fixes 

MacOS specific: 
§ Fixed job setup dialog to preserve the selected printer when "ask for page setup" & "ask for job 

setup" are used at the same time 
§ When internal print progress is used (counting pages), it uses the correct number of 

iterations/steps and is used when needed (the condition was reversed) 
§ Fixed loading of old MacOS7 PageSetup structure (missing bytes-wapping of a few fields 

resulting in incorrect paper size) 
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§ Fixed drawing with 4D v14 (when the window is in composite mode) 
§ Fixed drawing with 4D v14 in an external window (displayed garbage) 
§ Fixed an issue with the menus with 4D v14 

Windows specific: 
§ Fixed printing progress - was not closed when the page/job setup dialog was cancelled 
§ Fixed font chooser initialization (to correctly select font weight and to correctly compute the 

font size) 
§ When stored DEVMODE is used, the driver specific settings are preserved (accidentally it was 

not the case, thus there was no way to use e.g. scaling with a PS printer) 
o Note: this does not help when a different driver is used, the scaling is stored in driver 

specific area and thus it is not shared when another driver is used for printing 
§ Fixed picture handling when internal PDF generator is used on 64-bit 4D Server 
§ Fixed implementation of internal PDF generator  
§ Fixed strike-through line position  
§ Fixed drawing rotated text when internal PDF generator is used 

General: 
§ Fixed printing of empty text/variable/field on end of a page (again) - sometimes the object was 

moved to the next page even though there was enough space (noticeable with parallel repeating 
objects) 

§ Fixed print order when importing pre-3.x SuperReport Pro reports (order was reversed) 
o Note: previous versions showed [in the editor] print order 1 for top-most object (the last 

printed object), SuperReport Pro now uses 1 for bottom-most object (the first printed 
object in the container (group or section)) 

§ Fixed printing when first page header is used to fill the whole page (no break header/body fits 
on the new page) 

§ Fixed printing of empty text/variable/field when "remove if empty" is not specified (object was 
removed and objects below it moved up) 

§ Fixed printing of empty text/variable/field - nothing is printed (no frame and no background) - 
to be compatible with pre-3.x versions 

§ Fixed printing of sections using "keep together" - this setting was not honored 
§ Fixed moving/resizing of objects depending on other object resizing 
§ Fixed XML loading - leading spaces are preserved (e.g. a text object only containing a single 

space (" ") was interpreted as an empty string) 
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§ Fixed bug in script execution - empty case statement was executing code of the next case 
statement 
Case of 

: (True) // should continue on line after End Case 
 : (False) // but continued on next line 

ALERT ("Bug!") 
End Case 

§ Fixed various menu items not setting the defaults e.g. no object is selected, changing font size 
does not set the default font size (only toolbar items were setting the defaults) 

§ Fixed constant name SRP_Header_TextColor (was SRP_Header_HeaderColor) 
§ Fixed a bug in object move/resize (when an object is bound to bottom and is moved due to the 

removal of other objects above it) 
§ Field dialog updates the field list on type-ahead in the table list 
§ Fixed indication of invisible tables in the script dialogs (invisible are shown as italics) 
§ Fixed an issue when changing the page orientation on one platform then using the report on 

the other platform 
§ Fixed incorrect splitting of last row in a table object when multiple columns are set to calculate 

the height 
§ Fixed Table object printing the footers even when the table is set to not print them 
§ Fixed SR_SetXXXProperty returning no error when trying to modify read-only property 
§ Fixed a possible crash when removing footers from a table object 
§ Fixed a few bad formats in the XLF files 
§ Fixed "display preview" of numbers when "Use period and comma as placeholders in numeric 

formats" is active 
§ Fixed Progress dialog (using Page x instead of Page x of 1 when the number of pages is 

unknown) 
§ Fixed SRPrintSection variable to be C_LONGINT, not C_BOOLEAN 
§ Fixed 4D Edit menu updating in 4D v14 (workaround to bug ACI0088877) 
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Printing AreaList Pro areas 

AreaList Pro v9.4 and above allows printing or saving as HTML through SuperReport Pro v3. It only 
takes two lines of code to print an AreaList Pro area. Additional options are available, such as 
automatic column width and use of SuperReport Pro style properties instead of the existing AreaList 
Pro area settings. 

Note: use AreaList Pro v9.7 or higher and SuperReport Pro v3.2 or higher to print AreaList Pro areas 
with their footers. 

You can either use the built-in SuperReport Pro template to print an AreaList Pro area “on the fly” or 
create your own. 

The AreaList Pro Demonstration database now includes a “Print with SuperReport Pro” button in the 
“AreaList > Configuration Options…” dialog. It also includes a SuperReport menu, allowing printing 
with the default template or a custom template, and editing / creating your own templates. 

Please refer to the “Printing With SuperReport Pro” section in the manual for details about how to use 
SuperReport Pro to print AreaList Pro areas. 

Note: an “Extension to SuperReport Pro” license offer is available at 60 €: any non-unlimited AreaList 
Pro license type can now also include or be extended to a SuperReport Pro license. 

Contact 

SuperReport Pro 3.2.x is a free upgrade from version 3.0. 

Upgrade requests, sales and license information: sales10@e-node.net 

Technical issues, reports and requests: srp@e-node.net 

SuperReport Pro web page: www.e-node.net/srp 


