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The SuperReport Pro 
Interface

Following is a detailed description of the SuperReportPro interface.

The interface comprises a menu bar, toolbar, and report design area:

1
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The Menu Bar

File Menu

New: Create a new report.

Open ... : Open a report that has previously been saved to a file.

Close: Close the current report definition.

Save: Save the current report definition.

Save As ...: Save the current report definition as a new file.

Export ...: This option enables you to export the report to an HTML or plain text file:

The Menu Bar
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Print Preview: Create a preview of the report in PDF format. On MacOS: open it in the Preview application. On 
Windows: the default is to use the Microsoft XPS Document Writer, but it can be programmatically changed to use 
SuperReport Pro's internal PDF creator (see "Print Flags” in the SuperReport Pro Developer Manual).

Page Setup: Open the standard Page Setup dialog.

Print Job Setup: Open the standard Print Setup dialog.

Print: Print the report.

Zoom Window: Open an external window to display the report, on top of the 4D form (which remains open). The 
report can be edited in either window.

The Menu Bar

http://www.e-node.net/ftp/SuperReportPro/SuperReportPro_Developer_Manual.pdf
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Edit Menu

Undo ...: Undo the last change you made.

Cut, Copy, Paste, Clear, Select All: The usual functions.

Duplicate Object: Duplicate the selected object or objects.

Modify Object: This has the same effect as double-clicking the selected object:

 If no objects are selected, it opens the Report Properties dialog

The Menu Bar
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Change Object: Change the selected object type:

Position Object: This option allows you to specify precise coordinates for the selected object:

Modify Section: Edit the settings for the selected section. This option offers a flyout menu which lets you choose 
the Section you want to modify:

 
The Menu Bar
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You can modify various properties of the selected section:

The ID and Name fields can be useful in XML and HTML exports - for example, use ID as class-id for formatting.

Lock: Choose from three options: 

 n Unlocked - the section can be modified in any way by the user.

 n  Locked (selectable) - object can be selected (and then modified using Edit->Modify Object or double-click), 
but it can't be moved using the mouse.

 n  Locked (selectable) section can be selected (and then modified using Modify Object or double-click), but its 
objects can't be selected or modified in the user interface.

 n  Fully locked (not selectable) - The object/selection cannot be selected (although any object can be selected 
using Edit->Select Objects).

Position Sections: This sets the horizontal postioning of section markers:

The Menu Bar
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Add Section: This will display the Section management dialog, allowing you to add report sections, which are used for 
creating break processing reports, and also for adding a Watermark section. 

A Watermark section can be added to your report. This allows you to print a watermark on the report. The watermark 
is editable only when it is shown on top or no other section is visible.

 n When it is on top, objects from other sections are not selectable by mouse.

 n When it is on the bottom, objects from the watermark section are not selectable by mouse.

For more information about adding sections, see the Create a break processing report topic in the Tutorial section.

Show/Hide Sections: Selects which sections will be visible in the report:

The Menu Bar
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Report Options: Sets the general Report properties:

Select Objects: Displays a dialog to select one object from a hierarchical list of all report objects grouped into sections:

Insert Column(s) into a Table: Available when a Table object header, column or footer is selected. Inserts a colum at 
the left of the selected object. If several contiguous objects are selected, the same number of columns is inserted.

The Menu Bar
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Object Menu

The options under the Object menu enable you to manipulate selected objects in various ways. 

Bring To Front: Make the selected object(s) the frontmost.

Bring Forwards: Bring the selected object(s) up one level.

Send to Back: Move the selected object(s) behind all other objects.

Send Backwards: Move the selected object(s) down one level.

Order By Position: Re-order the selected objects by the top / left position.

Reverse Order: Re-order the selected objects in reverse order.

Group: Group the selected objects together.

Ungroup: Ungroup the selected objects.

Lock: Lock the selected object(s) so that they cannot be accidentally moved.

Unlock: Unlock the selected object(s) so that they can be moved.

The Menu Bar
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Align Objects: Align the selected objects as specified:

Hide: The selected object(s) will not be visible on the report. Note that making an object invisible has nothing to do 
with printing - this property is used only in the editor.

Hide Others: Hide all objects except the selected ones.

Show All: Un-hide all objects.

Font Name: Choose a font for the text of the object(s).

Font Style: Choose a style (Plain, Bold Italic, Underline) for the text of the selected object(s).

Font Size: Choose a size for the text of the selected object(s). Size increase and decrease submenu items step 
by one point.

Line Thickness: Choose a width for a selected line item.

Horizontal Text Alignment: Choose the alignment for the text of the selected object(s) - Default, Left, Centered, 
Right, Justified, Fully Justified).

Vertical Text Alignment: Choose the vertical alignment of the text within its text box (Default, Top, Center, Bottom).

The Menu Bar
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Increase Line Spacing: Increase the spacing (leading) between the lines of the selected text object(s). For example, 
an object with the default line spacing set might look like this:

Increase the spacing once and it would then look like this:

Decrease Line Spacing: Decrease the spacing between the lines of the selected text object(s).

Auto Wrap: Automatically wrap the text within the selected object(s).

Adjust Object Size by Style: Automatically adjust the height of the object according to the contents and the font size 
and style selected for the object. Note that this does not compute the "best object size" - it computes the nearest 
multiple of a full line height. For example, if you have 6 lines of text and the object shows 1.25 lines, it will shrink 
the object to 1 line. However, when the text is multistyled (attributed), the full height is used, because every line 
could have a different height.

The Menu Bar
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View Menu

Physical Page/Printable Area: If Physical Page is selected, the report design area represents a printed page, with 
the non-printing margins shown. The printable area is bounded by a dotted red line if the Show Margins options is 
also selected:

If Printable Area is selected, the report design area will show only the actual printable area of the report, without 
the page margins.

Show Ruler: If Show Ruler is selected, the vertical and horizontal rulers will be displayed; if it is not selected, they will 
be hidden.

Ruler Units: Select the unit of measurement for the rulers (Point, Millimeter, or Inch).

The Menu Bar
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Show Grid: Display the grid as dots in the background. If you can't see them, zoom in.

Snap to Grid: When moving objects, "snap" them to the grid.

Show Guides: Show any Guides that you have placed on the form. They appear as green lines:

In this example, we've set a horizontal guide at 250 Pt and a vertical guide at 500 Pt. To set a guide, click on the 
edge of the horizontal or vertical ruler so that the cursor turns into a little pointer  and drag up or to the left.

Snap to Guides: When moving objects, "snap" them to the Guides you've created.

Lock Guides: Lock your guides into position so that they cannot be moved.

Show Sections: If Show Sections is selected, the section names are displayed in a yellow box:

The Menu Bar
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Lock Sections: If Lock Sections is selected, the sections cannot be moved.

Show Margins: Show/hide the page margins.

Show Object Borders: If this option is selected, the borders of the objects in the report are displayed - e.g.:

If this option is not selected, the objects are displayed without their borders - e.g.:

Object Content: This is a very useful option which enables you to instantly see various information about all the 
objects on the report:

The following table illustrates the various options:

Option Example
Normal

Name

Alias

ID

Format

Print Order

Size

Value

The Menu Bar
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Original Size: Show the report at the zoom level that it was originally created in.

Zoom to 100%: Show the report at its actual printing size.

Zoom In/Zoom Out: Zoom into or kout of the report - make it bigger or smaller on the screen.

Headers/Footers For: Select which pages you want the header and footer areas to print:

The Menu Bar
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Database Menu

Report Table/Iterations: Display the Report/Table Iterations definition dialog, where you can set the main table for your 
report or how the number of iterations should be calculated in a repeating report:

 n  Selected Report table: Choose a table for the report to be based upon. The number of iterations will be 
determined by the selected number of records being printed.

 n  Fixed Number of Iterations: Enter a number to specify how many iterations will be printed.

 n  Use Value in Variable: Enter the name of a numeric variable which will contain the required number of iterations.

 n  Use Size of Array: Enter the name of an array; the number of iterations will be determined by the number of 
elements in the array.

The Menu Bar
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Select Records: Open the standard 4D Query Editor.

Order Selection: Open the standard 4D Order By dialog.

Select Printing Sections: Open a dialog which enables you to specify which sections will be printed:

All sections are selected for printing by default. An unselected section is shown in this way:

Scripts: You can write scripts to run during different events in the report execution cycle:

For an example of using scripts, see the Tutorial.

The Menu Bar
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The Toolbar
The Toolbar offers many options for designing and configuring your reports: 

First Row 

Selection Tool: Use this tool to select a specific report object to work with.

Note: to select one or several object(s) without dragging a box around the whole object(s) hold down the 
Alt / Option key while drag-selecting. All “touched” objects will be selected.

Text Tool: Create a static text object.

Field Tool: Create a field object.

Variable Tool: Create a variable object.

Line Tool: Create a line object.

Box Tool: Create a box object. Hold down the Shift key as you draw the object to create a square.

 Circle Tool: Create an oval or circular object. Hold down the Shift key as you draw the object to create a circle. 
When an Oval object is drawn, it initially appears as a rectangle. The actual shape can be seen when you 
have applied a line thickness and/or color, or fill color, to the object - for example:

The rectangle that you see is the object border.

Turn off View >Show Object Borders and you will see nothing unless the object is selected; once it is 
selected, you will see the frame and the resize handles.

When you open a new SuperReport Pro area, the default for both frame and fill is off, line thickness is 1 pt.

 (view set to Show object ID)

The Toolbar 
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You must change the frame / fill settings and possibly colors and thickness.

If you do it before the object creation (no object selected), it will be set as default. Then you will see the 
ellipse / circle during object creation.

(view set to Normal)

Picture Tool: Insert a picture and modify its properties. To insert a picture, either paste one from the clipboard 
or select the Picture tool and draw a box. If you pasted the picture, double-click on it to open the Picture 
Object Properties window; if you drew a box, the Object Properties window will open automatically:

To select an image, right-click/Ctrl-click on the square image box. A contextual menu pops up:

The Toolbar 
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Choose Paste to paste an image from the clipboard. Choose Import ... to open the file picker dialog to 
select an image file. The selected image will then be shown in the image box:

You can also drag and drop a picture onto the image box. Use the sizing options to determine how the 
image will be displayed within the box:

Table Tool: Insert a table. The Table dialog will open:

The Toolbar 
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n Options Tab

ID: You can change the default ID for the table if you want to.

Name: You can enter a name for the table.

Order: The order in which the object will be processed when the report is printed.

Fix Horizontal Position: If this option is selected, the object will always be printed in the same position (horizontally). 
Otherwise, its position may change, depending on the other objects being printed.

Fix Vertical Position: If this option is selected, the object will always be printed in the same position (vertically). 
Otherwise, its position may change, depending on the other objects being printed.

Number of Header rows: Usually you will want one header row, but you can create more by increasing this number.

Draw Headers: If this option is not selected, the table will be printed without any headers.

Number of Columns: Enter the number of columns you want in your table. You will be able to specify the contents of 
the columns in the next step.

Draw Data Columns: If this option is not selected, no data will be printed in the table. Why would you want to print a 
table with no data? You can use this feature to create a static table (no data rows) consisting of the header only with 
variable substitution in the header cells. It will resize the cells as needed and draw a nice table, with the ability to split 
over pages both horizontally and vertically.

Variable Row Height: If this option is selected, the height of each row will automatically adjust to allow for the row's 
contents.

Style: Select a stylesheet.

Visible: If this option is not selected, the table will not be visible on the report.

Export: If this option is selected, the table will be included in a text or HTML export of the report.

Lock: See the Lock options description earlier in this chapter.

Print: Four options are available:

 n No: The table will not be printed.

 n Yes: Print once (this means it will be printed even On Overflow if the object had not yet been printed.

 n  On Overflow: This option is for when a section is split across page boundaries. For example, you could create 
a text object "Continued ..." at the top of a section and choose the On Overflow option. It will then print only 
after the section is split.

 n Always: Always print.

The Toolbar 
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Frame: Choose No, Single, or Double.

 n Offset: The text inset within the cells, in points for both row and column dividers. The maximum is 20.

 n Thickness: The frame thickness, in points.

 n Color: The frame color.

Note: when the table frame is None, column and row dividers are not drawn and the Offset is not used! If you 
want to have row or column dividers (or both), set the frame to Single and frame thickness to 0. If you don't 
want any lines, set the frame to Single and all thicknesses to 0 to be able to use Offset as spacing between 
columns and rows.

Horizontal grid thickness: Width of the horizontal grid lines, in points. Enter 0 for no horizontal grid lines.   
The maximum is 20.

Vertical grid thickness: Width of the vertical grid lines in points. Enter 0 for no vertical grid lines. The maximum is 20.

Row Height: If you want to specify a row height, enter the value here. 0 means automatic.

The Toolbar 
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n Script
You can write a script to execute when the table is printed. This must be correct 4D syntax. Note the following 
information, which is specific to tables:

The script is run when lower-execution-level columns fetch a new row to allow SuperReport Pro to prepare the 
selection for this execution level. In other words, the script is not meant to be executed on every row, but as a 
query to get the column's data.

If you need to preprocess the values, use arrays.

When the section is fetched for execution, the section's script is run and then the scripts of all objects (in print 
order) are run. The table's column scripts are executed as part of the Table's script execution (to fetch data).

For the body section, the breaks are checked and the respective break headers/footers are executed and printed. 

Note that you can also attach scripts to individual columns (see below).

n HTML Data
On this tab you can enter HTML code - this will be executed when the report is printed to HTML. 

For example:

 <%tBegTagHTML%>   
 <table border=1 width=100%>

The <%tBegTagHTML%> section tells SuperReport Pro to insert the contents of the variable tBegTagHTML when 
this report is printed in HTML format.

The next line will create a standard HTML table to display the data.

The following example shows a table that has been set up with 4 columns, a single-line border in blue at 1 point, 
and row and columns dividers of 0.5 pt:

The Toolbar 
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n Modifying the Table

Adjusting column widths: Move your mouse pointer to the header divigng line and move it horizontally to resize a 
column (like a spreadsheet).

Headers: Double-click on a header to modify its text, set various Options, and choose the font and style.

Header Properties

ID: You can enter an ID if you wish.

Name: You can supply a name for the header object.

Order: the column order.

Row Span: If you want the data in the selected column to span more than 1 row, enter the number of rows here.

Column span: to make the header span more then 1 column, enter the number of columns hiere.

Column Width: If you prefer to enter a precise width (in points) instead of manually resizing the column, enter 
the value here.

Row Height: Leave this value at the default (0) for automatic height adjustment. Or enter a value for a specific 
row height.

The Toolbar 
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Parse for variables: You can embed variable references the same way as in Text objects (the table header is 
virtually a Text object). For example:

   "This is an embedded <%variable%>"

The full syntax for text substitution can be found in the SuperReport Pro Developer Reference (see "Dynamic 
text").

Multistyle (attributed): Allow styled text within the header. See the Styled (attributed) text section.

Column Properties

Double-click on a column body to edit its properties:

ID: You can assign an ID to the column.

Name: You can assign a name to the column.

Order: The column display and print order.

The Toolbar 

http://www.e-node.net/ftp/SuperReportPro/SuperReportPro_Developer_Manual.pdf
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http://www.e-node.net/ftp/SuperReportPro/SuperReportPro_Developer_Manual.pdf
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 Styles Popup Tool: You can create custom text stylesheets. To create a stylesheet, click on the Styles tool and 
choose Edit Styles ... :

The Toolbar 



The SuperReport Pro Interface
301

Click the New Style button to create a new stylesheet. Then double-click the new style to change its name 
and other properties:

Font Size Popup Tool: Assign the selected font size to the selected object(s).

Use Line/Frame Color tool: Click to apply the selected line width and color to the selected object.

 Line/Frame Color Tool: Open the color picker to choose a color to apply to the selected object or text. Click to 
select the line or frame color; option-click to select the font color.

Line Width Tool: Select the thickness of a line or frame.

The Toolbar 
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Second Row

Group Tool: Group the selected objects together.

Ungroup Tool: Ungroup the selected grouped objects.

Object Alignment Tools: When you have two or more objects selected, you can align them using these tools.

 

Text Alignment Tools: You can align and justify text, field, or variable objects using these tools.

Use Fill Color Tool: Apply the selected fill color from the Fill/Background Color Tool to the selected object(s).

 Fill/Background Color Tool: Open the color picker for you to select a fill/background color. Apply the selected 
color to an object with the Use Fill Color Tool.

Object Defaults
When a new object is created, the default values are used – not the currently displayed options. To change default 
value, use the respective tool to change them while there is no object selected. For example, to make the default 
line thickness and color for new objects such as rectangles and ovals 1 point, blue:

 n Make sure no objects are selected on the report.

 n Click on the Line width tool and select 1 pt.

 n Click on the Line/Frame Color tool and select blue.

 n Draw the required object.

The Toolbar - Object Defaults
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The Report Design Area

Section Marker Overview

SuperReport Pro provides the ability to create a variety of report types. When creating reports, you will need 
to adjust the Section markers to support the style of reports you wish to create. There are five different section 
markers available when creating reports.

n Header
The header section is printed once for each page. Typically, you will display report tiles, field titles, etc. in the 
Header section.

n Body
The body section is the primary section used by SuperReport Pro. This is where you will place the actual field or 
variable objects which you wish to have appear on your reports. If you are creating a break-processing report (we 
cover this in a bit), you can also place field or variable objects in the additional break sections.

n Total
The total section is where you will place report totals. If you are creating break-processing reports, you can also 
use the SubTotal sections to provide total information.

The Report Design Area
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n Footer
The footer section is printed once for each page. Typically, you will display report date and time information, or 
page numbers.

n Watermark
A Watermark section is not included by default. To add one, choose Add Section ... from the Edit menu.

Grids and Guides
When you are placing objects on the form, you can use Grids and Guides to help align all the objects nicely.

n Grid
To show the grid, select Show Grid from the View menu. The grid is displayed as small dots - if they are too small 
to see, try zooming in! Choose Snap to Grid from the View menu to make objects snap smartly into line when 
they are moved.

n Guides
You can create Guides to help you line objects up horizontally or vertically when you want to set precise positions. 
To create a Guide, click on the edge of the horixontal or vertical rule so that the pointer turns into a guide symbol:

 Then drag the pointer up or left to position the guide. 

Guides appear as light green lines:

If you can't see them, zoom in. 

Choose Snap to Guides from the View menu to activate the guides. 

The Report Design Area
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Resizing Sections
You can resize any section by moving the bottom section separator line up or down.

n Resize cursor
When you click on such a line or its marker label the cursor becomes “vertical resize”:

n Example
Moving the line or the marker up or down will shrink or expand the section above it.

Here is a header before resize:

Moving the separator line down increases its height:

n Effect on other sections and objects
Note that the sections and objects below the modified section will visually move up or down.

This has no effect on these section sizes or object placements. Since the sections are displayed one above the 
other, this movement only means: “Some section(s) above have been resized”.

The Report Design Area
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n Separators vs markers
A separator line can only be moved up or down. A marker can either do the same (with the same effect), or be 
moved horizontally for display convenience in the SuperReport Pro editor:

n Modifier keys
You can resize several sections at once using the shift key.

 n click on a section (or marker)

 n shift-click on another section (or marker)

➝ two sections are selected:

 n now click on the marker of one of the selected sections and move it

➝ both selected sections will be resized:

Also, during the drag of the marker(s):

 n shift key will limit the horizontal movement of the marker(s)

 n option key will limit the vertical movement of the marker(s) - section(s) will not be resized

The Report Design Area
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n Difference with previous versions
If you move a SuperReport Pro section marker, all section markers under the selected marker will move accordingly.

SuperReport Pro version 2 used only “lines” to define the start of a new section (similar to 4D form editor).

SuperReport Pro version 3 always moves all sections, because the sections are containers of objects and one of 
them is being resized - all other (not selected) sections are moved.

When moving a section label, hold down the Option key to move only the label horizontally (not to resize the 
section); hold down the Shift key to resize the section (not to move the label horizontally).

Table objects
Several tools and shortcuts are available for Table objects.

Insert Column(s) into Table (Edit menu item)

 n  The selection can be any of header cell(s), column(s), footer cell(s) of exactly one Table object (then the menu 
item is enabled)

 n  When multiple cells are selected, it will insert number of columns defined by the range (last selected column - 
first selected column) before the first selected column (defined not by the order the selection was made, but by 
the column order)

 n  When no column is selected, it will append 1 column

Move Table column(s)

 n Alt/option left/right arrow will move the selected column(s) including headers/footers to the left/right

 n The column must be selected (does not work for header/footer cells)

 n  Because the move is made on per-object basis, selecting two adjacent columns and using alt-right-arrow will 
do nothing: the first one is moved to the right (after the second one), then the second one is moved to the right 
(being now the second one again)

Delete Table column(s): DEL (or Edit > Clear menu item)
The column must be selected (does not work for header/footer cells)

The Report Design Area
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Object overflow
When an object overflows to the next section, a small red triangle is drawn to indicate that a possible problem 
may result:

The Report Design Area
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Tutorial - 
Introduction to the  
SuperReport Pro Editor

This section provides an overview of the various editor components and how they can be used to create reports. 
We will cover the following points:

 n Menu Overview

 n Creating a basic listing report

 n Creating a basic form report

 n Using Repeating Objects

 n Creating a basic break processing report

 n Creating an HTML report

 n Printing Arrays

2
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Menu Overview
SuperReport Pro provides a variety of menus and menu items which can be used to further customize your 
reports. We’ll introduce you to a few of the most commonly used menu items. 

Edit | Modify Object 
(Also displayed when you double-click on a report object)

This item will display the various object definition dialogs. Depending on the type of object you have selected, the 
corresponding dialog will be displayed.

SuperReport Pro Field Object Dialog

Menu Overview
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SuperReport Pro Static Text Object Dialog

SuperReport Pro Variable Object Dialog

Menu Overview
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Edit | Add Section
This item will display the Section management dialog, allowing you to add report sections, which are used for 
creating break processing reports. 

SuperReport Pro Add Section Configuration Dialog

Database | Select Records
This item will display the standard 4th Dimension Query Editor that will allow you to locate the records which you 
wish to include in the report. If you don’t perform any record selection, the current selection will always be printed.

File | Print Preview
This item allows you to preview the report before it is printed. 

Menu Overview
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Creating a Basic Listing Report
Now that you have had an overview of the SuperReport Pro toolbar, section markers, and basic menus, you are 
ready to begin creating your first report. 

1.  Add a new field to the report area. Each of the items should be placed in the Body section (above the Body 
marker). Select the Field Tool, then draw a box in the location where you would like the field located. The Field 
Object Properties dialog opens:

Select the field that you would like to place on the report for the new object.

2.  Repeat Step 1 to add a couple more fields (e.g. Customer Code and Telephone). Your report should look something 
like the following:

Creating a Basic Listing Report
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3.  Now, we’ll add the corresponding field titles. Using the Text Tool, create field titles for each of the fields you've 
added. While you are here, go ahead and apply some additional font formatting, such as making the titles bold. 
After you have completed adding the titles, your report should look something like the following:

4.  The next step is to set the Main Table for this report. For this example we’ll select the Customer table. Select 
Report Table/Iterations from the Database menu. The Report/File Iterations dialog will be displayed.

SuperReport Pro Table Selector Dialog

5.  We’re just about done. The last thing we need to do is establish a selection of records for the selected file. Choose 
Select Records from the Database menu. The standard 4th Dimension Query Editor will be displayed, which will 
allow you to perform any query you wish to establish the record selection.

6.  You should now save your report before continuing. Click the form's Save button (which will in turn, execute the 
Save code we created in the Using Plug-In Area section).

7.  Return to the record we just created by double clicking it from the report table output form. If you have successfully 
completed the steps described above, your report will appear in the report editor and you are ready to print your 
report! If you don’t see the report template you just created, please review the Using Plug-In Area section and 
make sure you have completed the related steps.

8.  Select Print or Print Preview from the File menu to print your report. If you don’t see any data, you will need to 
perform Step 5 again to establish a selection. SuperReport Pro does not maintain the selection; you will need to 
perform this task yourself before you print your reports. 

Creating a Basic Listing Report
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Creating a Basic Form Report
Next we’ll create a slightly more complex report: a form report. Like the listing report we just created, you’ll make 
use of the SuperReport Pro section markers. In addition, we’ll introduce a new dialog, the Section Definition 
dialog. 

Using the Section Definition dialog, you can customize the way SuperReport Pro prints your report. In the case of 
a form report, we don’t want the records to print one after another as they were in the listing report. Instead, we 
want to have each record appear on its own page.

The following steps will outline how to create a form report so that each record is printed on a separate page. 

1.  Using the SuperReport Pro demo, modify the “Customer Details” report definition (choose Report Definitions 
from the Demo menu). This contains a basic form report. Or create your own report, moving the body section 
down as necessary to create a form report.

2. Double-click on the Body section marker to display the Section Definition dialog:

3.  Select the Start A New Page Before Starting This Section radio button in the Page Breaking Options section.

4. Click OK to save the change.

5.  Now select the Print Report or Print Preview menu item from the File menu to see your new form report. As you 
can see, each record is printed on a separate page.

Creating a Basic Form Report
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Using Repeating Objects
One of SuperReport Pro’s unique features is its ability to print related many records as repeating objects. Using 
repeating objects, you create your reports in the same fashion as you normally would, placing parent table information 
in the body section.

With most reporting tools (such as the 4th Dimension form editor), if you want to print related many records, you 
are required to convert your reports to be based on the Many table, then print related one records.

SuperReport Pro provides the ability to include related many records as part of the primary table.

1. Create the report as you normally would, using fields from the parent table (Customer in the Demo database). 

2. Next, we’ll place the following fields in the Body section – fields from a related many table: 

 [Invoice]CreateDate
 [Invoice]Total

You can apply any type of data formatting you wish to get a feel for what SuperReport Pro has to offer in the 
way of displaying data.

3.  Double-click on the [Invoice]CreateDate field and click the Options tab in the Object Properties dialog. The 
following dialog will be displayed. 

Select the Repeat This Object check box and click the Use Vertical Repeat Offset checkbox, assigning a 
value of 2 points. This value will be the number of pixels between each repeated object. 

4. Do likewise for the Total field.

5. The next step is optional depending on the type of table relationship you have set up for the parent and many files. 

 n If your file structure is configured to use automatic relations, you don’t need to perform any further tasks. 

 n  If your file structure is configured to use manual relations, you will need to add the following code in the Body 
section markers scripts so that SuperReport Pro can get the related records at print time. 

    RELATE MANY([Customer])

Using Repeating Objects
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6. Save your report. 

7.  Now select the Print Report or Print Preview menu item from the File menu. The following example was created 
using the "Customer Details With Invoice History report" from the Demo database:

SuperReport Pro Repeating Example Preview

Using Repeating Objects
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Creating a Break-Processing Report
SuperReport Pro provides a very powerful break processing reporting system, providing up to six break levels. 
Using break processing you could, for example, create a report that prints a list of invoices, sorted by customer.

1.  The first step will be to define the main table for the report. Select Report/Table Iterations from the Database 
menu and select Invoice:

SuperReport Pro Main Table/Iterations Dialog

2. Click OK to save the dialog.

3.  The next step will be to set up the sections that we are going to be using on this report. Select Add Section from 
the Edit menu. When the Section Definition dialog is displayed, choose Break Header from the Type to Add 
popup menu, and leave the Add Corresponding Footer option selected:

 

Creating a Break-Processing Report
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4. Next we'll place the fields and labels in the appropriate sections:

Section Item Description

Header Section Invoice Sales Report Static Text Item

Report Date Variable

Break Header 1 Section (field headers) Invoice No Static Text Item

Date Static Text Item

Total Static Text Item

Body Section [Invoice]Number Field Object

[Invoice]CreateDate Field Object

[Invoice]Total Field Object

[Invoice]PayDays Field Object

Break Footer 1 Section (Subtotals) Total Line Line Object

vTotalTxt Variable Object

[Invoice]Total Field Object

Total Section (Report Totals) Grand Total Static Text Object

[Invoice]Total Field Object

Double Lines Line Objects (two separate lines)

Footer Section Page Number Variable Object (uses SRPage variable)

Once you have completed adding all the objects, you report should look something like this:

5.  The next step will be to configure the “Body” section script to set the vTotalTxt variable located in the Break Footer 
1 section. Double-click on the “Body” section mawrker to display the Section Definition dialog and select the 
Script… tab.

Creating a Break-Processing Report
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6. Enter the following text, then click the OK button to accept the script:

   vTotalTxt:="Total for Period "+[Invoice]Period+": "

Notice that the Body section label now has a shaded corner to indicate that there is a script attached to it: 

7.  Next, we need to configure the Break Header 1 section so that our break processing occurs correctly. SuperReport 
Pro calculates the breaks in a report based on one of three items:

 n The value of a field for a given table.

 n The value of a variable.

 n The value of an array element.

In our example, we are going to use the value of a field: the [Invoice]Period field. 

Creating a Break-Processing Report
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8.   Double-click on the Break Header 1 section to display the Section Definition dialog. You will notice the Only use 
this Section on Value Changes Of… item is enabled (page 1).

 n Select Only use this Section on Value Changes Of…

 n Select Field from the Object popup menu.

 n Select [Invoice]Period from the field popup menu.

9.   The next step is to establish a selection of records and define a sort order. If you don’t sort your selection, 
SuperReport Pro will not be able to correctly calculate the break, and your report will not appear as expected.

10.  Select Start Script… from the Scripts submenu, located in the Database menu. The SuperReport Pro Script 
Editor will be displayed. (We'll be providing more detail about SuperReport Pro scripts in the next section.)

Creating a Break-Processing Report
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Enter the following code:

   ALL RECORDS([Invoice]) // print the selection of invoice records
   ORDER BY([Invoice];[Invoice]Number;>)

Start Script Dialog

11. Save your report!

Creating a Break-Processing Report
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12.  Open the report and select Print Report or Print Preview from the File menu to see your report. It should look 
something like this:

Creating a Break-Processing Report
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Creating an HTML Report
SuperReport Pro gives users and developers the ability to include HTML tags in report objects which will be 
utilized when printing a report using SR_Export or SR_ExportIntoBLOB, or by selecting the HTML option when 
selecting Print To Disk from within the Report Editor.

Each object may contain a standard tag, which is sent before the actual data of the object, and an end tag, which 
is sent after the object data. 

Furthermore, when reports are printed in HTML format, all font attributes are retained and the corresponding font 
tags are sent automatically when the report is created.

The following steps will convert an existing report (the Basic Listing Report created in the first example) to be 
suitable for HTML output.

1.  Select Database | Scripts | Start Script and enter the following code. This will establish some variables which 
are used within the HTML report, as well as establish a record selection to print.

  tBegTagHTML:=”<html><body bgcolor=’#ffffff’>”
  tEndTagHTML:=”</body></html>”
  ALL RECORDS([Customer])
  ORDER BY([Customer];[Customer]Code;>)

Creating an HTML Report



Tutorial - Introduction to the SuperReport Pro Editor
542

2.  The next step will be to configure the Header section, which is where you assign the standard HTML header 
information. In addition to standard HTML tags, we’ll introduce the feature of using 4th Dimension variables as 
HTML token variables.

Double-click on the Header object, select the HTML Data tab, and enter the following text into the Header 
HTML Begin Tag field:

  <%tBegTagHTML%> 
  <table border=1 width=100%>

Header Section | HTML Data

The <%tBegTagHTML%> section tells SuperReport Pro to insert the contents of the variable “tBegTagHTML” 
when this report is printed in HTML format.

The next line will create a standard HTML table to display our data. . Since we are creating a listing style report, 
using an HTML table is a logical choice.

Creating an HTML Report
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3.  Since we have already created the table creation tag, we’ll jump forward a bit to the “Total” section where we 
placing the corresponding </table> tag. We place the close table tag in this section as it is where the report will 
actually end when the corresponding section completes printing.

Double-click on the Total section marker, click on the HTML Data tab, and enter the following HTML tag in the 
Begin section:

  </table>

If you were to create a break processing report where you had multiple sections, you could create nested tables 
by place the <table> tag in the SubHeader section, and the </table> tag in the corresponding SubTotal section.

Creating an HTML Report
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4.  The next step will be to insert the new row tags (<tr> and </tr>). The Body script is executed for each record in the 
current selection and it executes before the body section's object scripts.

Double-click on the Body section marker, click on the HTML Data tab, and enter the following HTML tags.

  Begin Tag: <tr>
  End Tag: </tr>

5.  Now that we have successfully created our tables, it is now time to add some data cells. Using the HTML <td> and 
</td> tags, we can create table cells for the current row.

For each field in the Body section, double-click on the field object, click on the HTML Data tab and add the 
following tags:

  Begin Tag: <td>
  End Tag: </td>

As each object in the body section is printed, a new cell will be created.

6.  The last piece of the body data will be to create a row for the data blocks in the header section. Since the scripts 
of these objects are executed after the header marker, we can create the first row of column data before the 
corresponding body section is executed.

For each object in the Header section which is a column title, double-click on the object, select the HTML Data 
tab, and add the following tags:

  Begin Tag: <td><b>
  End Tag: </b></td>

Creating an HTML Report
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These tags will create a single row containing the column headings, applying the bold HTML tag. You will notice 
that the End Tag section has the </b> tag before the </td> tag. As outlined in the first step, the Begin Tag is sent 
to the HTML file before the data is sent, the data is sent, and then the end tag is sent. If you were to place the 
</b> tag after the </td> tag, the generated HTML file would be incorrect.

7.  The final configuration item will be to close our HTML file. Since we placed the beginning HTML tags in the report's 
Header section marker, the logical place to place the closing HTML tags is in the Footer section.

Double-click on the Footer section marker, click on the HTML Data tab, and enter the following code:

   <%tEndTagHTML%>

Like the HTML header, the end tag is using a custom 4th Dimension variable to hold the standard end tag data.

8.  Now we are ready to create our HTML file, using the SR_Export command or by selecting Export… from the File 
menu and selecting the Output As HTML option in the Output Options section.

When exporting using HTML output, remember to select the Print Static Text Items option and All Sections, 
otherwise your HTML data will be incomplete.

Creating an HTML Report
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Styled (attributed) text
Multistyled text (a.k.a. “attributed”) can be printed in the various object types: variables, text, fields, table headers 
and table columns. This feature is activated in the object Options tab, Multistyle checkbox.

 n Make the text multistyled (attributed):

 n Add attributes to modify the style using simple tags: a list of supported tags can be found in the SuperReport 
Pro Developer Reference (see “SuperReport Pro Text Style Tags”):

 n Then the word "bold" is actually bold:

Note: if you want to use variables in the otherwise static text (Parse for variables is checked), you have to 
encode special characters (instead of using <%variable%> you must use &lt;variable&gt;).

Styled (attributed) text
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Printing Arrays
While SuperReport Pro provides an extensive feature set for printing 4th Dimension database fields, we didn’t stop 
there! SuperReport Pro can also print 4th Dimension arrays, whether it be a full array (all elements in the array), 
or a specific array element — SuperReport Pro can handle it!

The following tutorial will teach you how to create a SuperReport Pro report for printing a group of arrays. In 
addition, we’ll discuss how to configure the Report Table/Iterations dialog to use the array size instead of the 
number of records in a selection as we have in previous examples.

Using the Customer Listing report we created in the first example as a template, perform the following tasks.

1.  Replace all field reference objects with new variable objects.

Click on the variable tool in the SuperReport Pro Editor Toolbar, draw a box in the same location as the original 
[Customer]Code field, and assign a variable name of aCCode (for Customer Code) and select the Variable Type 
to be Array (Automatic).

Array Variable Object

Printing Arrays
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2. Repeat Step 1 for each of the following variable names

  aCName Customer Name
  aCTel  Customer Phone
  aCFax  Customer Fax

Your report should now look something like this:

Sample Array Report

3.  The next step is to define the report iterations based on the size of the array we are printing. Since all the arrays 
will be of equal size, we can select any of the arrays to define the report iterations.

Select Report Table/Iterations from the Database menu. When the dialog is displayed, select the Use Size Of 
Array radio button and use the aCCode array.

Report Iterations based on array size

Printing Arrays
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4. The last step is to create the arrays. 

Select Start Script from the Scripts submenu, located in the Database menu.

Enter the following code and save the script:

  ALL RECORDS([Customer])
  SELECTION TO ARRAY ([Customer]Code;aCCode;[Customer]Name;aCName;[Customer]Telephone;aCTel)
  SORT ARRAY(aCCode;aCName;aCTel;>)

5. Save your report, then re-open it.

6. Select Print Preview or Print from the File menu to see your report.

Printing Arrays
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Hints and Tips

Feel free to extract this chapter (courtesy of Gallery Systems) and distribute it to your users. You are also welcome 
to enhance it: send us any improvement that you'd like to include!

The SuperReport Pro advanced reporting tool has been completely rewritten and has significant new functionality. 
Legacy report templates will automatically convert to the new format.

Note: once converted, the reports can no longer be used with the old version, so be sure to make backups.

The following list covers some of the new functionalities.

1.  Templates are stored in XML format. Previously, templates were required to have a .SRP file extension. While 
.SRP is still supported, the new default is .XML. It is now possible to open the XML template files with a text editor.

2.  Preview opens in PDF format on Macintosh and XPS format on Windows. While PDF is a default system 
configuration on all Macintosh machines, the new XPS format may not be configured on Windows workstations. 
More information about downloading the viewer is available here. If XPS Viewer is already installed on your 
system but not set as the default for viewing XPS files, it may be necessary to adjust the default viewer for this 
file type in Control Panels.

3.  Support for Columns: SuperReport Pro version 3 supports columns, so legacy templates that used the NEXT 
RECORD scripting command may be updated. Records may be set to print vertically (down the page) or 
horizontally (across the page). To adjust a template, open it and then choose Report Options from the Edit 
menu. Note however that the old behavior is supported: reports using NEXT RECORD will still work.

4.  Multi-Style Text: this new setting should be applied for any Object Notes fields or Report Text where the new rich 
text functionality has been enabled.

5.  Selecting Objects: hold Opt/Alt to select groups of objects with just a touch. This mimics the previous behavior 
of the old versions of SuperReport Pro. Otherwise, you must drop a complete box around the report object to 
select it. You can also use the menu: Edit > Select Objects.

6.  Cursor Control: want to move selected items a bit more quickly? By default, if you select an item (so that it has 
corner squares), then use the keyboard arrows to adjust the position, it will only move 1 point at a time. Go to 
the Edit menu and choose Report Options, then adjust the Arrows Move By value to anything from 0.1 to 5 
(5 is fastest). Use Shift + arrow keys to move by 10 times the preset value.

7.  Grouping allows elements to be associated. For example, it might be useful to group the text box for a field label 
with the field/variable data it describes. Select both objects and then choose Group from the Object menu.

8.  Locking: individual elements on a template may now be set as Unlocked, Locked (selectable), and Fully 
Locked (not selectable). These options may also be applied for entire report sections (such as the Body or 
Footer). Essentially, when an element is Locked, it can not be moved with the cursor (preventing undesired 
changes).

Hints & Tips
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9.  Zooming in Design View: having trouble seeing the little boxes on the report editor? Choose Zoom In from the 
View menu.

10.  Embed HTML styles into Text objects. E.g. “Some <b>Bold</b> text”. Be sure to click the Multistyle (attributed) 
checkbox on the Options tab.

11.  Line Spacing (Leading): if a field has wrapped multi-line text, you can adjust the spacing between lines. Double-
click the object and go to the Font tab and enter a value such as ".5" to bring lines closer together or "2" to 
double-space. Or use the menu: Object > Increase Line Spacing / Object > Decrease Line Spacing.

12.  Rotation: need to print text on its side? Double-click the object and go to the Font tab. Adjust the rotation value 
to any number between 1 and 360 (or leave at None).

13.  Framing: each report object can be configured to have a frame (border). Double-click the object and go to 
the Options tab. Click the checkbox for Frame. Offset allows for the control of the amount of white space 
between the data and the frame. Thickness allows for control of the weight of the frame. Color provides a 
pop-up picker to choose the color of the frame. If the object is of variable size, it is best to draw it at a smaller 
size and then set the Print with Variable Width and/or Print with Variable Depth boxes (also on the Options 
tab) so that the object and its frame grow dynamically.

14.  Adjust Object Size by Style: when a report element (box) is drawn, it may be any size. The command in the 
Object menu called Adjust Object Size by Style will adjust the size of the object according to the font size 
and style selected. If the field uses the Multistyle option, the size cannot be adjusted because each record 
could have text of variable size.

15.  Sections: when sections are adjusted (by clicking on the line that says Header or Body, for example), the 
contents of the other sections move along with them automatically.

16.  Multiple Header and Footer Sections: it is now possible to create up to 3 instances of the Header section. One 
might be set to print on the First Page Only, another for the 2nd (and other middle pages) and the third for the 
Last Page Only. Sub-headers are now called Break headers.The Total section is now called Break footer. Note 
that for the Last Page to work, you need to check the option Calculate number of pages in the Edit > Report 
Options dialog. Otherwise the last page header/footer will be never printed.

17.  Watermarking: go to the Edit menu and choose the Add Section command. Select Watermark from the 
popup list. By default, it is set as the topmost layer so that can be edited. Once a watermark image is in place, 
uncheck the On Top setting. To modify the watermark section, choose Modify Sections from the Edit menu 
and select Watermark. Check the On Top box to edit.

18.  Show Object Content: go the View menu and choose Object Content. It is now possible to see an assortment 
of useful values - including a preview of the data from the record (such as the Display Title or Thumbnail).

19.  Insert Picture: go to the Toolbar and select the icon that looks like a roll of film. This will allow you to draw 
a Picture Object box (perhaps for a logo graphic). Right-click the picture box on the Properties window to 
Paste an image or select Import… to browse to a file (or even use drag-and-drop!). Various properties such 
as Frame settings may be assigned.

20.  Tables: the Toolbar icon to the right of the Insert Picture icon is the Table Tool. This tool offers a tremendous 
amount of functionality. Tables offer a great solution for printing Object-related content. With the older versions, 
fields from these tables could be drawn on the report and set to Repeat. However the repeating fields had to 
be set with a fixed Repeat Offset - so fields with varying length of content might get cut-off (or show too much 
white space). The Table Tool has a Calculate Height option that can automatically calculate the varying data 
height required to display content. Note that there may be some limitations with the ability to use variables and 
apply advanced scripting.
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21.  Styles Popup Tool: another Toolbar icon allows you to create saved styles. For example, you can create a style 
called “Headers” that would be defined as Arial Font - Size 24 - Bold. Select an object, then click the Styles 
Popup to automatically set it with all of these properties.

22.  Page count: you can now calculate the number of pages in the report via Edit > Report Options in order to add 
a footer like “Page 1 of 9”. It will fully process the report to get the count, and then process it a second time 
(which may be awkward for reports that include alerts or prompts in the scripts).

23.  No 80 character limit on text fields: as AlphaNumeric fields in 4D increased from 80 characters to a maximum 
of 255, the old report writer could only print 80 characters unless the field was assigned to a variable. This 
workaround is no longer required.

24.  Setting Print Order: the Print Order of objects on the report is especially important when exporting the data in a 
report to a text file. In the previous version of SuperReport Pro, the only way to reset the order was to use the 
tedious Send to Back command. With SuperReport Pro version 3, a new command in the Object menu allows 
for selected objects to be Reordered by Position. You can even choose to Reverse Order. Additionally, by 
opening the Properties window for any object, you will find an Order field on the Options tab. Additional 
options allow you to specify if the Object should be Printed or Exported at all.
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